Suppress Zemax Message during macro execution

  • 28 September 2020
  • 2 replies

Hi, I'm running Zemax Optic Studio Professional, version 20.2.2.

Whenever I'm working with large pixel arrays, or high (> 1024 x 1024) sampling in physical optics propagation, and my detector viewer/beam file viewer is set to text view, I get a message box saying 'Text is too long to display. Use Copy All or Save As' to retrieve the entire file'. 

This message box doesn't cause a problem as I'm exporting the data in a macro anyway, but it means that during a long macro where I'm running POP multiple times, I have to constantly watch OpticStudio as it pauses the macro until I dismiss the message box, which is obviously impractical. 

Is there a way to either 

a) Increase the maximum allowed text file to be displayed within OpticStudio, or

b) Suppress the message box, as the data export is absolutely fine

Thank you!


2 replies

Userlevel 6
Badge +2

Hi Michael,

How are you extracting the data with your macro? Is it through a Numeric Function like GETT or GETL? Or is it through the keyword GETTEXTFILE? I think this pop-up is probably appearing because the POP window is open on your screen. If you use GETTEXTFILE, then you will be able to extract the POP window data without needing to open the Physical Optics Propagation tool at all. That should allow you to avoid the pop-up message.

Here is an example of what I mean:



In this image, you can see that the only windows I have open are the macro and the Text Viewer output. I am still able to extract the data and print it to the Text Viewer. I can also choose to simply save the data without re-printing it with something like this:


! Macro sample to generate cardinal points in a file.

! Get a temporary file name


! Compute the data and place in the temp file



You can use this in conjunction with MODIFYSETTINGS to update the POP settings and save the new output. Without MODIFYSETTINGS, the output will match the settings last saved to the CFG file. Could that work for you instead?

Let me know if you are still seeing this pop-up even without opening the POP analysis. 




Hi! Thank you very much, I was able to adjust my macro using this information and can do my analysis on larger datasets as required. 

Thank you so much for your help!