Solved

Overlay not available in 3D layout toolbar button

  • 15 November 2021
  • 4 replies
  • 35 views

Hi,

The overlay button is unavailable in my OpticStudio (Version 21.2.1) 3D layout or shaded model, but I do see it in pretty much all the other graphics, such as Huygens PSF, polarization analysis, field curvature, etc..  It’s so strange! Does anyone have a solution to make the layout button appear in the layout graphics?

Regards,

Nathan

icon

Best answer by Jeff.Wilde 16 November 2021, 05:47

View original

4 replies

Userlevel 3
Badge +2

I think the Active Overlay feature is designed to overlay *data* plots, not graphics windows.  That’s why it is not available for layout windows.

 

 

Hi Jeff,

Thanks for taking the time to answer my question.  

Yes, but according to the section “Graphics and Text Windows Operations” of the users manual overlay should work for 3D layout too.  In the past I was also able to overlay the graphics, such as in a multi-config model, just as the manual suggests its usefulness.  

 

 

Regards,

Nathan

Userlevel 3
Badge +2

 Ok, I think I figured out what is going on.  Try activating the “Classic View” setting: 

 

 

Now, close your file and then open it up again.  The 2D Layout window should have an overlay feature available in the Classic view tab:

 

 

You can clone this layout window, display a second configuration in the new clone window, and then overlay the two layouts:

 

 

However, there is still no overlay feature for the 3D Viewer and Shaded Model layout windows. 

Hope this helps…

Hey, that works!  I have also tried turning on Enable Class View, but I didn’t close out OpticStudio and restart.  Thanks so much, Jeff.  This kind of thing should be documented in the users manual.

 

Regards,

Nathan

Reply