Issue with sag map

  • 23 September 2022
  • 2 replies


I want to be able to use step files in Zemax, so I followed the following tutorial :

So I added the file given at the begining of the article and clicked on NSC Sag, and then a blank box opens and the setting button on there is not doing anything. 



So my questions are : Is there everything ok with the software ?

If yes, what am I doing wrong ?


Have a nice day,




Best answer by MichaelH 23 September 2022, 19:07

View original

2 replies

Userlevel 6
Badge +2

Hey Jerome,

Everything appears to be working.  When I open the ZAR, it only has 1 STEP file object and when I first launch the NSC Sag Map, I get the following screenshot:



Then, when I open the Settings, I need to make sure to change the Face to a valid face which will have rays striking it from the +z direction; the default Face 1 has no rays hitting it so I change it to Face 0.  I have also changed the width and decenters so Face 0 is centered in the display:


This gives the following sag map:


To help understand what is going on with the NSC Sag Map, I suggest clicking on the “advanced” right arrow in the bottom right of the Settings and checking the Keep Saved Files box:


This will save a modified file to the current directory (as nsc_sag_map.zmx) with the array of Source Ray used to probe the object so you can see the intermediate steps of the calculation.  This Source Ray has to hit the selected Object and Face to return valid results.

Thanks for your answer Michael. 

It seems that I have an issue with this function. I will try to find the cause of it and solve it.