Creating source from CAD file

  • 11 June 2021
  • 1 reply


I am trying to create a source from a CAD object file. I have created a source object immediately under the CAD file and set the parent row number to the row of the CAD file. As soon as I run the ray trace I get the “unknown error”. Please se the screen shot attached.

Could you please assist with what the reason could be and how to resolve it?





1 reply

Badge +3

Hi Nitin,

Thanks for your post here on the forum!

A potential solution:

It could be that the ACIS libraries is what causes the NSC object to fail to render properly in the layout window and subsequently causes OS to issue this Error.

Let`s test it out!

If you go to the Setup tab > Project Preferences > General

You can uncheck the “Use ACIS Libraries” box

So now you can updated the layout window with the “ACIS Libraries” unchecked and checked, and see what happens.

If that won’t do the trick or if you have tried it already, please come back to me either here in the forum (Just reply in this Forum Thread), or if you want to share a file, but you don’t want to publish it here in the Forum. You can just open a “Private case” within MyZemax so only Zemax employees can see your file.

Thank you and I look forward to hearing from you!

Best, Flurin