Solved

TCMU Tolerance

  • 25 January 2023
  • 6 replies
  • 39 views

Userlevel 1
Badge

There’s a “Nominal” field associated with the TCMU tolerance.  With other tolerances (like TRAD), the nominal field is populated with a non-zero value but I don’t see that nominal field being populated with regard to coating layer thicknesses.  Is the user expected to input each layer thickness in the “nominal” TCMU field or is that not necessary?  Thanks. 

icon

Best answer by Jeff.Wilde 26 January 2023, 03:55

View original

6 replies

Userlevel 5
Badge +2

Hi James,

The nominal value is a read-only field so you will not be able to enter anything in this column; all other columns in the TDE are editable but not the nominal column.

When I try this (Ansys OpticStudio 2022 R2.0), I actually get the value from the LDE’s Surface Property:

If you’ve already checked the Use Layer Multiplier and Offsets and made sure the TDE’s Surf and Layr columns match the Surface and Layer values in the LDE, then I would suggest maybe trying to reboot OpticStudio.

Userlevel 6
Badge +3

The layer thickness control is just a multiplier (or scale factor) that is applied to the physical thickness as defined in the coating file.  Before adding a TCMU operand to the TDE, it is probably best to first “turn on” the coating layer control.  Here’s an example in which I placed a 4-layer coating on the first lens surface:

 

If I select Layer 3, for example, then the following options are shown:

 

You can see that the Thickness Multiplier defaults to 1.  You can obviously change this to a different value or make this parameter a variable for optimization.  If you change layers, the same default settings are present.

Now, if you go to the Tolerance Data Editor and load a TCMU operand for any layer on Surface 1, you will see the Nominal value auto-populate to a value of 1 (or whatever value was entered in the previous screen).  However, if the coating control has not been activated for a surface, then 0 shows up for the nominal value (e.g., see Surface 2 below):

 

Hope this helps…

Regards,

Jeff

Userlevel 1
Badge

Michael, Jeff,

Thanks for the responses and, yes, I did neglect to click the “Use Layer Multiplier and Offsets” box first.

Okay, if you look at the 1st attachment, you’ll see in the Tolerance Data Editor that I’ve put in a +/-3% layer variation on everything (factors of 0.97 to 1.03).  However, after I run a Monte Carlo analysis, the TCMU values are all varying about a value of 2.0.  Any idea what’s going on there?  Seems fishy. . . .  See also 2nd attachment for multiplier value in resultant Monte Carlo file.  

Thanks.

Alex

Userlevel 6
Badge +3

Fishy indeed.  I might have some time later this evening to try and replicate.

Jeff

Userlevel 6
Badge +3

@James.Fry:

Okay, I should have recalled this straight away, but in any event the min/max values are *changes* from the nominal.

 

So, if you use +/- 0.03 with a nominal value of 1.0, then you will see +/- 3% changes in the coating thickness.

Regards,

Jeff

Userlevel 1
Badge

It’s all so clear now, Jeff!  Thanks for the guidance.

Reply