Split NSC Rays in Non-sequential mode

  • 27 October 2019
  • 2 replies

I read in the "Exploring Non-sequential Mode in OpticStudio" tutorial that I need to select "Split NSC Rays" in order to see the effect of a beamsplitter in my design.However, checking the "Split NSC Rays" causes rays to split in other pieces of my design, including a plano-convex lens that I downloaded from the "How to create a simple non-sequential system" tutorial. Is my lens actually splitting the light, or is this just a side effect of clicking "Split NSC Rays?" See attached pictures.notnsc.pngnsc.png

Best answer by David 27 October 2019, 22:41

View original

2 replies

Userlevel 6
Badge +4

Hi Kathleen,

Your lens is splitting the light due to Fresnel reflections at glass-air boundaries. When you turn on splitting, it also turns on Polarization and OpticStudio splits rays. There are several ways to control this:

To see rays split in the layout, turn it on in the layout settings dialog:

To spit rays in analysis, turn on splitting in the ray trace control:

Sometimes you don't care about tracing rays below a certain intensity threshold. You can control that in the Non-sequential section of the System Explorer. Below I set it to not propagate ray child that has fallen below 7% of the initial parent intensity. This affects the analysis as well as the display:

Userlevel 2
I have this problem all the time.  I used to do what David suggested but if you forget to change the minimum ray intensity back to something sensible you can waste a lot of time with incorrect analyses!  You can also set each unwanted reflection to the I.9999999 perfect coating.  But again you might want to analyse with a real coating.

You know, it would be nice to have a check box "Do Not Split Rays At This Face" to make this easier..

Better still, adding a "Do Not Draw Split Rays At This Face" check box would be good.   A bit like this.....