internal reeflections in solid CAD file

  • 16 August 2021
  • 1 reply

I import a CAD assembly SolidWorks and explode it(SAB format) but when do the ray tracing and make the opacity of the CAD files to lower , I set all faces of the CAD files to the mirror and after ray tracing I see that rays are reflected internally inside the CAD file. like it is a shell and not a solid!! but it is solid. how can I solve this issue?



Best answer by Csilla Timar-Fulep 24 August 2021, 15:33

View original

1 reply

Userlevel 5
Badge +2

Hi Shamim,

Thank you for your question here on the community forums.

How did you set all the faces to be mirror, did you apply a coating or did you set the Face Is property to be Reflective? If you chose Reflective, the faces will behave as if the optical material is defined as "MIRROR", and rays approaching the face from either side are reflected. And did you set it on all faces manually one-by-one or did you group the faces together and then set the properties? If you would like to set the same properties for the faces, then might worth grouping them together to avoid the manual settings and the possible errors. You may change the face assignments under Object Properties > CAD:

The method of how the change the face assignments and how to apply coat/scatter properties on CAD parts is discussed in this knowledgebase article:

How to add coatings and scattering functions to Non-Sequential objects – Knowledgebase (

Is it possible that the properties are not set correctly for all of the faces and therefore rays get inside the CAD part and are trapped there because the other faces are set to reflect? I would suggest to double-check the face assignments and if possible group the faces together.

Also, are the surfaces of the CAD part in contact with any other surfaces? If so, for both the Material and Coating properties the rule is that the LAST object listed in the NSC Editor determines the properties of the overlapping areas. Is it possible that the surface properties were overwritten by another overlapping object listed later in the NSC Editor? Please double-check the object placement and the glue distance in the model . For more info, please see the Help system at:

The Setup Tab > Editors Group (Setup Tab) > Non-sequential Component Editor > Non-sequential Overview > Object Placement

The Setup Tab > Editors Group (Setup Tab) > Non-sequential Component Editor > Object Properties (non-sequential component editor) > Coat/Scatter

Switching the Fletch Rays option on on the Shaded model might also help in visualizing and solving the problem.

If these don’t help to solve your problem, would you mind sending over your design as a .ZAR archive file so that we can take a look and help troubleshooting? If the file is proprietary, you may open a private case on the website or email us to