IGS CAD Export error

  • 30 September 2021
  • 6 replies

Userlevel 1

I’m facing a weird problem while exporting .igs files from both sequential and non-sequential designs.

When importing into Solidworks 2017 all doublets have one of the two components transformed into a full sphere.

Moreover, an empty part is imported togheter with the design assembly.

I don’t know if its a matter of lack of compatibility with old Solidworks version, or just me having the sw configured in a bad way.




Best answer by Sandrine Auriol 4 October 2021, 12:29

View original

6 replies

Userlevel 6
Badge +2

Hello Alberto.

Thank you for reporting this issue. In version 20.3, we added new CAD libraries called the ACIS libraries that are more reliable and faster, but we are still correcting some issues. One of these known issue is when exporting doublets to IGES. It has been reported to our developers and they are working with the libraries vendor to get it fixed. If you’d like us to check, please send an email with your system at

In the meantime we would recommend using more standard formats such as SAT which is the native ACIS libraries format or STEP. Otherwise you can always switch back to our “old” CAD libraries. Untick “Use ACIS libraries” under Set-up…Project Preferences. 


Userlevel 1

@Sandrine Auriol thank you for the support.

I tried both ways:

_ exporting SAT files did not help. The generated SAT cannot be read by Soldworks 2017, regardless of the SAT version used. Anyway what I need is an assembly file to be imported into Solidworks. SAT files generate only parts, not assemblies, as far as I know.

_ switching to the old CAD libraries did the trick.

On V22.1 and still suffering from this issue. STEP and IGES exports very bugged in my experience.

The fix mentioned above works perfectly. I don’t know what it great about the ACIS Libraries, but they burned at least 10 hours of my time before I found the fix…



Userlevel 6
Badge +2

Hi David

Really sorry about that. Our developers are working on a larger initiative investigating our CAD libraries, which will include performance studies as well as CAD related bugs. In the meantime, yes switch back the old libraries.

After I disabled the ACIS libraries CAD exports worked fine - no problem. I then forgot about this bug.

Monday I downloaded 22.1.2 and today I spent an hour struggling to Export a CAD file with Solid Beams. Silly me! Having downloaded a new version, my project preferences are over-written. So the cursed ACIS libraries are back… 

Disabled them again and I got on with my job.

Please change the default to ‘disable’ on these ACIS libraries!



Userlevel 1

The same issue is still there on version 23.2.1 and new Parasolid libraries. Are there any news from the development team? 

Thank you and kind regards