Solved

Zemax on Windows emulators

  • 7 December 2020
  • 9 replies
  • 271 views

Hi Zemax users,


I am considering running Zemax Professional version on a Macbook Pro using a Windows emulator and an old style hard Zemax USB key.  Is there an emulator that is better than others for running Zemax seamlessly?  Ideally would like to be able to save Zemax generated output to the Mac side of my machine.  What has been your experience?

icon

Best answer by Berta.Bernad 7 December 2020, 16:21

View original

9 replies

Userlevel 3
Badge +2

Hey Chris,

You can read a comparison between Boot Camp vs Parallels Desktop vs VMware Fusion in this article. But it would be also interesting to hear from other users!

Userlevel 7
Badge +3

I used Zemax (v 13 and earlier) on Mac using Parallels Desktop for a long time back in the day and it worked perfectly. The only things to note:



  • A USB device can only be controlled by one OS at a time. This wasn't a problem, as the Zemax key couldn't be used by the Mac anyway, but it means that the port the key was plugged into was not available to the other operating system

  • You need a full Windows installation, and all anti-virus, patching etc that you would deploy on a full Windows machine.

  • Macs don't have an Insert key on their keyboards for some unfathomable reason but a little Googling will get the equivalent keypress combo. I can't remember it now :-(


None of those are unreasonable in any way, except maybe the lack of an Insert key, and it worked solidly for me for about 4 years. I had Zemax and Quicken on the PC-side, everything else on the Mac-side. I used Coherence mode, so both Zemax and Quicken looked like native Mac apps, with window control icons on the left, direct access from the Mac desktop and everything. I did this on my home machine to avoid Vista and Windows 8, but with Windows 10 I decided it wasn't worth it and now I just use W10 for everything.


- Mark

Thanks, Berta and Mark, for that excellent info!


Chris

Badge

For the past 5 years I have run OpticStudio on my Intel-based MacBook Pro, with Parallels Desktop and Windows10, and it ran fine (maybe a bit slow).  I now got a new MacBook Pro with the Apple M1 chip, and ran into problems:  I did get Windows 10 running with Parallels Desktop beta-version for M1, and Windows 10 Insider development version for M1.  However, when I tried to retrieve my OpticStudio license to the new MacBook Pro, I hit a wall, with the license not being retirevable.  After iterations with Zemax Tech Support, the conclusion was that the problem is between Sentinel and Windows 10 Insider version.  Sentinel say on their web site that they don't support  Windows 10 insider, and my trials seem to show that Sentinel SW is not compatible with that Windows either.  It seems that I have to wait until Microsoft release Windows 10 for the M1 chip.  I would love if Zemax could find a workaround (besides me using a PC), for example giving new MacBook users a temporary license-free OpticStudio for, say, 3 months.

Userlevel 6
Badge +2

Thank you for your feedback Joel. I'll send a message to your account manager.

Userlevel 7
Badge +3

Hi guys,

Is this issue with the M1 Macs fixed yet? I used Parallels for years on an Intel-based Mac without any issues, and I’m jonesing for an M1-based MacBook Pro.

  • Mark
Userlevel 7
Badge +3

Well, it’s going to be a Mac Studio, heh heh 😁But I wonder if OpticStudio will run at all on the Windows for ARM processor version (which is what the special version of Windows is)? At the least, it will need to be recompiled for ARM machines, I’d think.

Badge

I think it is time to pick up on this discussion again.  What has happened meanwhile is that I now have Windows 11 on my M1 Mac, but neither OpticStudio nor License Manager launch.  According to the information from Zemax OpticStudio tech support, Sentinel/Thales (the vendors for the licensing SW) don’t support the M1 yet.  However, even if the licensing SW were available, it wouldn’t do me any good, as OpticStudio doesn’t launch even to the point where it starts screaming of not having a license.  It seems to me that as long as Zemax (or now Ansys) don’t have a working M1 version, pointing fingers at Sentinel/Thales won’t help.

Don Dickinson at Zemax tech support (a very helpful guy) indicated that he had heard through the grapevine that some users had gotten OpticStudio to work on an M1, but could get any details.  Anyone heard of this?

For me this is - besides on a personal level - a problem, as I teach college courses, where OpticStudio is an integral part of the syllabus, and some of the students have M1 Macs - and can’t run OpticStudio on these.

 

Userlevel 7
Badge +3

I think it will require a major development effort to get OS to run on the M1. Back when Macs were really just PCs with a different operating system you could get virtualization to work well, but the M1 will require specific support I think. Don’t hold your breath.

Reply