Solved

Prisms in exported STEP files turn out weird with ACIS libraries enabled

  • 31 August 2021
  • 5 replies
  • 63 views

Badge

When ACIS is enabled, prisms turn out weird in the exported STEP files. The first surface is fine, but then the prism extends a long way in the wrong direction. 

icon

Best answer by Hui Chen 16 September 2021, 02:43

View original

5 replies

Userlevel 4
Badge +2

Hi @Michael.Weber 

Thank you for reporting this. I can confirm that this is an active bug report which is currently in the hands of our developers. Are you able to share an example of the prism you are building? It will be helpful to know if you are using Coordinate Breaks, Tilted surfaces, or some other method to generate the slanted faces. 

If you are more comfortable sharing a privately, feel free to open a case with us here: Profile – Zemax.

I will be sure to post a reply to this post when there is an update from our developers. 

Badge

Hi Allie,

thanks for your answer!

The prism is constructed using coordinate breaks, I attach a small screen-shot. 

Michael

 

Userlevel 2
Badge +1

Hi Michael,

Did you try disabling the Use ACIS option and see if the CAD export works fine that way? You can do so in the Setup tab\Project Preferences\General. If so, then this might be an issue with the ACIS libraries for CAD export.
It’s hard to say what might have caused the CAD export issue just based on the screenshot. Would it be possible for you to share the file with us so our developers can take a look? If the file is proprietary, you can either open a support ticket with us to share the file privately, or you can create a dummy file that demonstrates the issue so we can look into it. 

Best,

Hui

Badge

Yes, I did try to disable ACIS (as mentioned in the original post) and that does solve the problem. But as it took me a long time to find out about that option, I thought I should report it.

There is a simple prism example on your webpage using surface tilts, not coordinate breaks. I tried that, and it shows the same behaviour.

I attach the archive from your webpage, I used the simple file “Single Prism.ZMX”.

 

Kind regards,

 

Michael

 

 

Userlevel 2
Badge +1

Hi Michael,

Thank you for sending in the file. 

Yes, currently if you turn on the Use ACIS option, the CAD export may not work properly exporting beam splitter made using CBs. This is a known bug in the ACIS libraries for CAD export. Our Development team is aware of this and is working to resolve the issue.

Thank you for bringing this to our attention and we’ll keep you posted if there is an update on the issue. 

Best,

Hui

Reply