Coating EO_MGF2(550nm) on surface 1 not defined in coating file

  • 4 March 2020
  • 2 replies

Hello Everyone, 

While trying to use a doublet from stock lenses from any manufacturer specially from EdmundOptics, I am receiving the error message "Coating EO_MGF2(550nm) on surface 1 not defined in coating file". Can someone help me out with this issue, I tried all the possible solutions from internet but couldn't manage to solve this issue. 

Your help is highly appreciated. 

Best regards

Best answer by Berta.Bernad 4 March 2020, 15:38

View original

2 replies

Userlevel 3
Badge +2

This error may be caused by your COATING.DAT file, so first thing I’d do is checking if this coating in actually in your coating file. To do it, go to Libraries > Coating Tools > Edit Coating file:

The coating should appear at the bottom of the .DAT file. Once you have checked it, reload the Coating File and type the name (EO_MGF2(550NM)) in the Lens Data Editor coating cell.

I’d also recommend to check that this file is in the folder \\Zemax\COATINGS, as appear in the Project Preferences, as well as the encrypted file EO_MGF2(550nm).ZEC. If not, I’d suggest to re-install OpticStudio.

Find also attached a copy of the COATING.DAT file included in the latest release and the encrypted file, so you can copy it into the coating folder. To be safe, please backup copy your original COATING.DAT file to other folders.


Thanks Berta Bernad for the quick help. It works now :)